Background Image

Forum

2017.11.27 15:12

cubrid 실행 시 오류

조회 수 42 추천 수 0 댓글 13
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요. 
OS
aix7.1
CUBRID Ver.
CUBRID-9.2.1.0020-AIX-ppc64.sh
CUBRID TOOL Ver.
[도움말]-[버전정보] 확인
응용 환경(API)
java, php, odbc 등 입력

* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.
에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축


-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------
cubrid를 aix에 설치하고 cubrid service start 시 다음과 같은 오류가 발생합니다.


-bash-4.2$ cubrid service start

Could not load program cubrid:

Could not load module /home/cubrid/CUBRID/lib/libcubridsa.a(libcubridsa.so.0).

        Dependent module /opt/freeware/lib/libstdc++.a(libstdc++.so.6) could not be loaded.

        The module has an invalid magic number.

Could not load module cubrid.

        Dependent module /home/cubrid/CUBRID/lib/libcubridsa.a(libcubridsa.so.0) could not be loaded.

Could not load module .


cubrid_rel 실행 시 에도 다음과 같은 오류가 동일하게 발생합니다.




ldd cubrid 명령어를 수행 시의 상태입니다.


-bash-4.2$ ldd cubrid

cubrid needs:

         /home/cubrid/CUBRID/lib/libcubridsa.a(libcubridsa.so.0)

         /usr/lib/libc.a(shr_64.o)

         /usr/lib/libpthread.a(shr_xpg5_64.o)

         /opt/freeware/lib/libgcrypt.a(libgcrypt.so.11)

         /opt/freeware/lib/libstdc++.a(libstdc++.so.6)

         /usr/lib/libcurses.a(shr42_64.o)

         /opt/freeware/lib/libgcc_s.a(shr.o)

         /unix

         /usr/lib/libcrypt.a(shr_64.o)

         /usr/lib/libc.a(shr.o)

         /opt/freeware/lib/libgpg-error.a(libgpg-error.so.0)

         /usr/lib/libcrypt.a(shr.o)

         /opt/freeware/lib/libintl.a(libintl.so.8)

         /usr/lib/libpthreads.a(shr_xpg5.o)

         /opt/freeware/lib/libiconv.a(libiconv.so.2)

         /usr/lib/libpthreads.a(shr_comm.o)

  • ?
    정만영 2017.11.27 15:41

    안녕하세요.

    AIX CUBRID 버전은 다음과 같은 AIX package를 설치해야 합니다.

    필요패키지: bash, gcc, libgcc, libstdc++, libgpg-error,libgcrypt

    참고로 CUBRID 설치 전 계정을 bash shell로 변경 후 설치하고 root가 아닌 CUBRID를 위한 계정을 생성해서 큐브리드를 설치하세요.

    (AIX에서 root shell를 변경할 경우 OS부팅에 문제가 발생할 수 있습니다.)

  • ?
    김개미 2017.11.27 16:06
    cubrid를 위한 계정을 생성해서 큐브리드를 설치했고 필요패키지도 모두 설치 한 것 같은데 다음과 같은 오류가 발생합니다.
  • ?
    정만영 2017.11.27 16:13
    ldd 명령어로 aix7-2/>ldd /opt/freeware/lib/libstdc++.a 파일을 확인해 보세요.

    ex) ldd /opt/freeware/lib/libstdc++.a
    ldd: /opt/freeware/lib/libstdc++.a: File is an archive.
  • ?
    김개미 2017.11.27 16:17
    -bash-4.2$ ldd /opt/freeware/lib/libstdc++.a
    ldd: /opt/freeware/lib/libstdc++.a: File is an archive.

    ex와 동일하게 뜹니다.
  • ?
    정만영 2017.11.27 16:23
    CUBRID설치한 계정을 bash shell로 변경해서 설치 하셨나요.?

    ex) echo $SHELL
    /usr/bin/bash
  • ?
    김개미 2017.11.27 16:27

    -bash-4.2$ echo $SHELL
    /usr/bin/bash
    -bash-4.2$ id
    uid=294(cubrid) gid=208(cubrid) groups=1(staff)

    네 bash shell로 변경하여 설치 하였습니다.

  • ?
    정만영 2017.11.27 16:44
    $CUBRID/bin 위치로 이동해 ldd cubrid 명령어를 수행 후 cannot find 메시지가 있을 경우 해당 package를 찾아 설치해 보세요.
  • ?
    김개미 2017.11.27 16:49
    bash-4.2$ ldd cubrid
    cubrid needs:
    /home/cubrid/CUBRID/lib/libcubridsa.a(libcubridsa.so.0)
    /usr/lib/libc.a(shr_64.o)
    /usr/lib/libpthread.a(shr_xpg5_64.o)
    /opt/freeware/lib/libgcrypt.a(libgcrypt.so.11)
    /opt/freeware/lib/libstdc++.a(libstdc++.so.6)
    /usr/lib/libcurses.a(shr42_64.o)
    /opt/freeware/lib/libgcc_s.a(shr.o)
    /unix
    /usr/lib/libcrypt.a(shr_64.o)
    /usr/lib/libc.a(shr.o)
    /opt/freeware/lib/libgpg-error.a(libgpg-error.so.0)
    /usr/lib/libcrypt.a(shr.o)
    /opt/freeware/lib/libintl.a(libintl.so.8)
    /usr/lib/libpthreads.a(shr_xpg5.o)
    /opt/freeware/lib/libiconv.a(libiconv.so.2)
    /usr/lib/libpthreads.a(shr_comm.o)

    cannot find 메세지가 뜨지 않습니다. 전에 canot find 메시지가 뜨는 패키지를 모두 설치한 상태 입니다.
    혹시 환경변수 그런 문제인가요..
  • ?
    정만영 2017.11.27 17:19
    환경변수 문제라면 cubrid service start 명령어 수행 시 "command not found" 오류가 발생해야 합니다.

    cubrid service start 수행 후 "Dependent module /opt/freeware/lib/libstdc++.a(libstdc++.so.6) could not be loaded" 오류는 패키지 호환성 이슈나 라이브러리 파일 위치 또는 권한 문제로 보입니다.
  • ?
    오명환 2017.11.27 17:33
    맨처음 올려주신 오류에 보면 libstdc++.so.6에서 The module has an invalid magic number. 오류가 발생합니다.
    cubrid binary와 libstdc++ library가 안 맞는 것 같습니다.

    libstdc++-4.6.1-1.aix7.1.ppc.rpm 과 gcc-4.6.1-1.aix7.1.ppc.rpm 를 받으셔서 설치 후에 다시 실행해보세요.
  • ?
    김개미 2017.11.28 09:55
    libstdc++-4.6.1-1.aix7.1.ppc.rpm 과 gcc-4.6.1-1.aix7.1.ppc.rpm 를 재설치해도 똑같은 오류가 발생합니다.
  • ?
    주영진 2017.11.28 10:13
    /opt/freeware/lib/libstdc++.a 파일의 경우 심볼릭 링크가 걸려 있습니다.
    아래와 같은 경로를 가리킵니다. (4.8.3 : 버전은 다를 수 있습니다.)
    /opt/freeware/lib/libstdc++.a -> gcc/powerpc-ibm-aix7.1.0.0/4.8.3/libstdc++.a

    1. 해당 경로에 실제로 파일이 존재하는지 확인 부탁드립니다.

    그리고 cubrid를 설치하는 계정 홈 폴더에 있는 .cubrid.sh 파일을 열어보시면 LIBPATH가 어떻게 잡혀있으신가요?

    .2. 아래와 같이 잡혀 있으신 상태에서 위 파일과 버전이 일치하는지 확인 부탁드립니다. (4.8.3)
    LIBPATH=$LIBPATH:/opt/freeware/lib/gcc/powerpc-ibm-aix7.1.0.0/4.8.3/pthread/ppc64
    실제 '/opt/freeware/lib/gcc/powerpc-ibm-aix7.1.0.0/4.8.3' 이 디렉터리까지 가셔서 위 디렉터리 구조와 필요한 파일들이 있는지 확인해보시기 바랍니다.

    만약 심볼릭 링크 파일과 .cubrid.sh 파일의 LIBPATH 버전이 다를 경우 .cubrid.sh 파일을 수정하여 버전을 맞춰주시기 바랍니다.

    예를 들어 .cubrid.sh 파일에 LIBPATH가 4.6.1.버전을 가리키고 있는데
    LIBPATH=$LIBPATH:/opt/freeware/lib/gcc/powerpc-ibm-aix7.1.0.0/4.6.1/pthread/ppc64
    실제 libstdc++.a 파일이 가리키는 경로는 4.8.3 버전이어서 LIBPATH 경로를 아래와 같이 수정해주었습니다.
    LIBPATH=$LIBPATH:/opt/freeware/lib/gcc/powerpc-ibm-aix7.1.0.0/4.8.3/pthread/ppc64

    .cubrid.sh 파일 수정 후에는 해당 계정의 재 로그인을 한 후에 다시 cubrid 명령을 실행해보시기 바랍니다.
  • ?
    김개미 2017.11.28 10:33
    횐경변수가 문제 였던 것 같습니다. libstdc의 경로가 재대로 설정 되어 있지 않았던 것 같습니다.
    너무 감사드립니다..

List of Articles
번호 제목 글쓴이 날짜 조회 수
2736 오류가 이런게나서 이중화 한쪽이 안올리가는데 무슨에런 인가요? 1 coolkkm 2017.12.09 13
2735 CUBRID/conf/cubrid_broker.conf 파일에 auto_commit 설정이 없으면 추가해야 하나요? 1 coolkkm 2017.12.08 13
2734 데이터베이스 별 사용량 확인및 처리 방법 1 coolkkm 2017.12.07 14
2733 HA기능 WINDOW서버 3 러브뱌뱌 2017.12.07 16
2732 cubrid server 시작 시 fail 1 김개미 2017.12.05 20
2731 많은 레코드 건수를 반복적 저장하는 방법 1 산신령 2017.12.04 18
2730 loadb 인덱스 처리 옵션 문의 입니다. 1 coolkkm 2017.12.04 17
2729 testdb_t숫자, testdb_x숫자 형식으로 있는 파일 삭제 해도 되나요? 3 coolkkm 2017.11.30 22
2728 급합니다. 이중화 상태에서 한쪽 db가 죽어서 다시 살리는 방법 좀 알려주세요 3 coolkkm 2017.11.30 29
2727 Overflow occurred in addition context 오류 1 엑팩 2017.11.29 21
» cubrid 실행 시 오류 13 김개미 2017.11.27 42
2725 aix에 cubrid 설치 시 오류 1 김개미 2017.11.23 18
2724 큐브리드 파일 내보내기 스케줄 기능 문의 1 쿨쿨 2017.11.23 20
2723 백업시 한번 한 백업폴더에 다시 백업시 문제... 2 하일레곤 2017.11.23 19
2722 인덱스가 가끔 깨집니다. 도와주세요. 2 훈이아빠 2017.11.21 33
2721 쿼리 조회시 인덱스를 타지 않고 full scan 으로 나오는 경우 질문드립니다. 3 file 덴드로비움 2017.11.20 39
2720 DB연계과정에서 에러코드 발생되어 문의 드립니다. 1 file kik 2017.11.20 26
2719 clob에서 varchar(1073741823) 으로 변경된 테이블 조회시 오래걸리는 현상 4 최범규 2017.11.17 45
2718 UPPER 를 이용한 like 검색 과 한글 문제 1 akasima 2017.11.16 30
2717 연계과정에서 질문드릴게있습니다. 1 qswaert 2017.11.16 23
Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 ... 137 Next
/ 137

Contact Cubrid

Tel. 070-4077-2110 / Email. contact_at_cubrid.com
Contact Sales