Background Image

FORUM

조회 수 42 추천 수 0 댓글 5
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요.
OS
Windows 10 64bit, Ubuntu 16.04 64 bit
CUBRID Ver.
CUBRID 9.3
CUBRID TOOL Ver.
[도움말]-[버전정보] 확인
응용 환경(API)
Python 3.6 

* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.
에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축


-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------


윈도우와 리눅스 환경에서 파이썬 라이브러리 설치하는데 오류가 발생하여 문의드립니다.


먼저 리눅스 환경 질문드립니다.


-Ubuntu 16.04 x86_64


pip install CUBRID-Python


명령어를 통해 모듈 설치는 진행하였습니다.


그런데, 


import CUBRIDdb


conn = CUBRIDdb.connect('CUBRID:localhost:33000:demodb', 'public', '')


소스를 실행하면


Traceback (most recent call last):

  File "CUBRID_TEST.py", line 3, in <module>

    conn = CUBRIDdb.connect('CUBRID:localhost:30000:demodb', 'public', '')

  File "/home/ubuntu/.local/lib/python2.7/site-packages/CUBRIDdb/__init__.py", line 61, in Connect

    return Connection(*args, **kwargs)

  File "/home/ubuntu/.local/lib/python2.7/site-packages/CUBRIDdb/connections.py", line 22, in __init__    self.connection = _cubrid.connect(*args, **kwargs2)

_cubrid.InterfaceError: (-20002, 'ERROR: CCI, -20002, Invalid connection handle')


위와 같이 -20002 에러가 나옵니다.


파이썬 모듈 설치에 빠진 사항이 있는지 확인 부탁드립니다.


다음으로는 윈도우 환경입니다.


-Windows 10 x86_64


홈페이지에서 9.3 파이썬 라이브러리를 다운로드 받은 후 


압축 해제하여 파이썬 라이브러리 폴더에 이동시켰습니다.


파이썬 코드 상에서 


import CUBRIDdb


를 하게 되면

CUBRIDdb/__init__.py  의


import _cubrid 


쪽에서 에러가 발생합니다.


에러는


ImportError: No module named _cubrid


인데


_cubrid.pyd 파일이


존재하는데 다음 에러가 떠서 어떻게 해결 하면 좋을지


답변 좀 부탁드리겠습니다.





  • ?
    김병욱 2019.09.09 11:30
    안녕하세요...

    conn = CUBRIDdb.connect('CUBRID:localhost:33000:demodb', 'public', '')
    위 구문을 아래와 같이 변경해서 실행 보시기 바랍니다.

    conn = CUBRIDdb.connect('CUBRID:localhost:33000:demodb:::', 'public', '')
    user-id와 password가 Connection URL에 항상 포함되어야 합니다.
  • ?
    JayHan 2019.09.09 16:39
    답변 감사드립니다!

    잘 작동하네요!
  • ?
    김병욱 2019.09.11 11:03
    안녕하세요...

    문의하셨던 내용 중에 윈도우에서 파이썬을 사용했을 때, import CUBRIDdb 에서 오류가 발생한다고 하셨는데, 현재 윈도우에 설치된 Python 버전을 알려주시면 좀더 정확한 답변을 드릴 수 있겠습니다.
    참고로, 현재 큐드리드에서 공식적으로 배포되는 드라이버는 Python 2.7과 Python 3.6을 지원하고 있습니다.
  • ?
    JayHan 2019.09.11 14:21
    python 3.6 버전으로 진행하였고 윈도우 파이썬 라이브러리 다운받아 압축풀어서 사용했으며
    import 과정에서 위의 에러가 발생하고 있습니다.
  • ?
    김병욱 11 시간 전
    안녕하세요...

    현재 홈페이지에서 제공되는 파이썬 드라이버 9.3의 경우 Python 3.2 버전에 적용되는 드라이버로 Python 3.6 버전과 호환되지 않을 수 있습니다.
    추후 파이썬 드라이버 9.3에서 Python 3.6버전이 호환될 수 있는 버전을 준비하도록 하겠습니다.
    우선은 파이썬 드라이버 10.1에서 Python 3.6 / Windows 64Bit 버전을 다운 받으셔서 사용하시기 바랍니다.

List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 SQLGate for CUBRID를 사용해 보시기 바랍니다!!! file admin 2019.07.31 139
3041 큐브리드 함수에 관한 문의 드립니다. 1 update OCKS 2019.09.11 20
3040 큐브리드 매니저 관련 문의 드립니다. 1 file 팩트드림 2019.09.10 20
3039 CUBRID SHARD 문제 질문드립니다. 2 JayHan 2019.09.09 49
» 파이썬 라이브러리 설치 질문드립니다. 5 update JayHan 2019.09.07 42
3037 Unable to register the CUBRID Service Tray. Retry? 메시지 팝업문제 민수킴 2019.09.02 28
3036 charset 문의드립니다. 1 투다닥 2019.09.02 16
3035 쿼리문의드립니다. 2 투다닥 2019.08.30 29
3034 REST api 지원 여부 1 몰라알수가없어 2019.08.29 27
3033 검색 단위 설정 해제하는 방법 문의드립니다. 2 마데카21 2019.08.23 38
3032 varchar의 글자수 제한 스펙 문의 1 kirito 2019.08.22 75
3031 관리자 권한이 없을 때 실행이 안됩니다(실행 직후 종료) 2 카페타임 2019.08.21 49
3030 테이블 컬럼 구하는 쿼리좀....... 1 wewek3jk3 2019.08.20 34
3029 큐브리드 서버는 돌아가고있는데요 큐브리드 매니저 연결이안되는 이유가 무었일까요 ??? 4 왜안왔어 2019.08.20 42
3028 group_concat null 질문 1 wndud 2019.08.19 22
3027 java class load시 JNI모듈 에러 1 file centerist 2019.08.13 41
3026 데이터 베이스 load 명령어 실행 중 Maximum value 오류 1 pqow770 2019.08.06 48
3025 php 7.3 버전에도 설치가 가능한가요 ? 1 kks8017 2019.07.31 36
3024 like 공백 제거 검색방법 알려주세요. 1 초초초보 2019.07.31 47
3023 시점 복구 test 문서 연람 방법 문의 5 file 공중정원 2019.07.26 125
Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 ... 153 Next
/ 153

Contact Cubrid

대표전화 070-4077-2110 / 기술문의 070-4077-2147 / 영업문의 070-4077-2112 / Email. contact_at_cubrid.com
Contact Sales