루비 2.x 드라이버 지원 문의

by enak posted Oct 11, 2015

* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요.
OS
Windows x64
CUBRID Ver.
9.3.2
CUBRID TOOL Ver.

응용 환경(API)
ruby 2.2.3

* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.
에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축


-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------
CUBRID를 루비에서 사용하고자 하였으나 큐브리드의 버전은 9.3.X까지 지원하나 큐브리드 홈페이지(.org)를 살펴보니 루비 버전은 1.8.X까지 지원하는 것 같습니다.


현재 2.2.3버전까지 루비가 출시되었는데 해당 버전에서 큐브리드 드라이버 설치 후 Cubrid.connect('demodb') 코드 실행시 Segmentation fault오류가 발생합니다. (rubygems와 cubrid는 require로 로드함)


이에 지원을 하나 제가 세팅 과정에서 잘못 진행한것인지, 아직 지원하지 않는다면 향후 루비 2.X버전에 대해 지원 예정이 있는지 문의드립니다.


Articles

87 88 89 90 91 92 93 94 95 96