Background Image

FORUM

?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요.
OS
CentOS 7.6.1810
CUBRID Ver.
8.4.1.32003
CUBRID TOOL Ver.
[도움말]-[버전정보] 확인
응용 환경(API)
php 5.4.16

* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.
에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축


-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------


CentOS 7.6.1810 에서 8.4.1.32003 버전의 큐브리드 데이터 베이스로 php 5.4.16 를 이용하여 접근하려 합니다.

어떤 드라이버 소스를 사용해야 할까요? (http://ftp.cubrid.org/CUBRID_Drivers/PHP_Driver/8.4.1/Linux/ )

또 소스 빌드 외로 좀 더 쉽게 드라이버를 설치할 수 있는 방법에 대해서도 궁금합니다!


빠른 답변 부탁드립니다!

  • ?
    주영진 2019.04.03 23:23

    안녕하세요.
    문의주신 내용은 모든 버전에 맞게 빌드되어 있지 않아서 PHP Driver 소스를 빌드하는 방법 밖에는 없습니다.

    생각보다 방법이 간단하기 때문에 어렵지 않으실 겁니다.

    아래와 같은 방법으로 진행하시면 잘 되실 겁니다.

    ----

    # CentOS Release 확인
    shell> cat /etc/centos-release
    CentOS Linux release 7.6.1810 (Core)

    # PHP 설치 및 버전 확인
    shell> yum install -y php php-devel
    shell> rpm -qa | grep php
    php-cli-5.4.16-46.el7.x86_64
    php-common-5.4.16-46.el7.x86_64
    php-5.4.16-46.el7.x86_64
    php-devel-5.4.16-46.el7.x86_64

    # configure, make, make install 단계에서 필요한 Package 설치
    shell> yum install -y make gcc ncurses-devel libstdc++-static

    shell> wget http://ftp.cubrid.org/CUBRID_Drivers/PHP_Driver/8.4.1/Linux/CUBRID-PHP5-8.4.1.2032.src.tar.gz
    shell> tar -zxvf CUBRID-PHP5-8.4.1.2032.src.tar.gz
    shell> cd cubrid-php-8.4.1.2032/php5
    shell> phpize
    Configuring for:
    PHP Api Version: 20100412
    Zend Module Api No: 20100525
    Zend Extension Api No: 220100525
    shell> ./configure --with-cubrid=/home/cubrid/CUBRID
    ...
    shell> make
    ...
    shell> make install
    Installing shared extensions: /usr/lib64/php/modules/

    # 'Scan for additional .ini files in: /etc/php.d' 경로 확인
    shell> php --ini
    Configuration File (php.ini) Path: /etc
    Loaded Configuration File: /etc/php.ini
    Scan for additional .ini files in: /etc/php.d
    Additional .ini files parsed: /etc/php.d/curl.ini,
    /etc/php.d/fileinfo.ini,
    /etc/php.d/json.ini,
    /etc/php.d/phar.ini,
    /etc/php.d/zip.ini

    # 위에서 확인한 경로 cubrid.ini 생성
    shell> cat << EOF >> /etc/php.d/cubrid.ini
    extension=cubrid.so
    EOF

    # 연결 테스트
    # localhost, 30000, demodb 등의 정보는 환경에 맞게 변경
    shell> php -r 'if (cubrid_connect("localhost", 30000, "demodb")) { echo "connect\n"; } else { echo "fail\n"; }'
    connect


List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 SQLGate for CUBRID 영구 무료 라이선스 제공 file admin 2020.04.09 1493
3523 회원가입이 3명이상 안돼요.. 1 딩이 2010.07.08 7828
3522 회사 서버에 접속을 할려면 설정이 다른가요? 2 후니 2009.07.14 10463
3521 홀따옴표 처리 문의 1 초보 2010.04.15 14646
3520 혼합형 데이터 정렬방법 1 큐키 2021.06.11 41
3519 혼합형 데이터 정렬 방법 1 큐키 2021.06.14 45
3518 혹시 큐브리드매니저 자동완성 끄는 기능 있나요 2 안지민 2012.09.05 5915
3517 혹시 큐브리드 매니져 기본글꼴을 고정폭으로 해주실 생각은 없으신가요... 1 안지민 2012.12.20 5702
3516 혹시 PHP5.3.0 버전에서 모듈 설치되신분 계신가요??? 4 senseplus 2009.07.13 9329
3515 혹시 MMDB 지원하나요? 1 tekkal 2009.01.31 17393
3514 호스트 추가시 발생되는 오류에 대해 문의 합니다. 1 거북이사촌 2015.01.06 5199
3513 호스트 추가 질문입니다. 7 몽유객 2010.12.21 13746
3512 호스트 추가 1 karay2k 2011.12.17 17851
3511 호스트 연결이 안됩니다. 3 file 미드소나 2013.01.01 7710
3510 호스트 연결이 안되요.(비밀번호오류) 2 양희종 2011.09.06 13727
3509 호스트 연결이 되지 않습니다. 3 file Juooon 2013.07.24 9156
3508 호스트 연결 에러 3 secret PJEPJE 2016.01.28 10
3507 형변환 오류 문의 1 삽질중 2009.12.30 12934
3506 현재 큐브리드 7.1 을 사용하고 있는데요 1 헬리 2009.10.01 8739
3505 현재 이중화 진행중인 db 를 한쪽을 끊고 이관작업이후 이중화를 붙이면 동기화가 문제가 없나요? 1 coolkkm 2017.10.30 299
3504 현재 연결은 원격 호스트에 의해 강제로 끊겼습니다 1 바람바람 2013.05.29 83086
Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 ... 177 Next
/ 177

Contact Cubrid

대표전화 070-4077-2110 / 기술문의 070-4077-2147 / 영업문의 070-4077-2112 / Email. contact_at_cubrid.com
Contact Sales