centos8 64bit 환경에 큐브리드 10.2 버전 설치 오류

by 푸르른하늘 posted Oct 20, 2020

* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요.
OS
Linux 64bit
CUBRID Ver.
[cubrid_rel] 수행 결과
CUBRID TOOL Ver.
10.2
응용 환경(API)
java, php, odbc 등 입력

* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.
에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축

-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------
아래 순서대로 설치를 진행하였습니다.

0. 계정생성
useradd cubrid
su - cubrid

1. download
wget http://ftp.cubrid.org/CUBRID_Engine/10.2/CUBRID-10.2-latest-Linux.x86_64.sh

2. 스크립트 실행
sh CUBRID-10.2-latest-Linux.x86_64.sh

3. 초기설정파일 실행
. /home/cubrid/.cubrid.sh

4. CUBRID 서버, 매니저, 브로커 실행
cubrid service start

오류 #1) 위 2번 단계에서 아래와 같은 오류(Cannot create demodb.)가 발생하였습니다.
중략... 
Extracting, please wait...
Unpacking finished successfully
Cannot create demodb.

오류 #2) 위 3번 단계에서 아래와 같은 오류가 발생하였습니다.
[cubrid@localhost ~]$ . /home/cubrid/.cubrid.sh
[cubrid@localhost ~]$ cubrid service start
cubrid: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

해결 방법에 대해 도움을 받고자 합니다.
감사합니다.


Articles

8 9 10 11 12 13 14 15 16 17