Background Image

FORUM

?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

안녕하세요 리눅스 서버에 설치하면 두가지 문제가 발생하였습니다.

저희 서버 환경은 아래와 같습니다.

Red Hat Linux 3.2.3-42 , gcc version 3.2.3,Linux version 2.4.21-50.ELsmp

root계정으로 /usr/local/CUBRID 밑에 설치를 하였습니다.

설치를 하면

CUBRID has been successfully installed.

Cannot create demodb.

와 같이 데모db를 생성할 수 없다고 나옵니다.

그리고 .cubrid.sh 를 실행후에

[root@UnetwareVersantDB root]# cubrid service start
cubrid: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
[root@UnetwareVersantDB root]# echo $LD_LIBRARY_PATH
/usr/local/CUBRID/lib:/usr/local/versant/vds605/lib:/usr/local/versant/vds605/lib/cxxchk:/usr/local/versant/vds605/lib/jvi/1p:/usr/l
ocal/versant/vds605/jre/lib:

현재 시스템에 libstdc++.so.5 는 /usr/lib 에 존재하는데 libstdc++.so.6은 없습니다.

어떻게 하여야 하는지요?

[root@UnetwareVersantDB usr]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2.3/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix
 --disable-checking --with-system-zlib --enable-__cxa_atexit --host=i386-redhat-linux
Thread model: posix
gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-42)





  • ?
    janus 2009.01.22 20:11
    안녕하세요. CUBRID를 사용해 주셔서 감사합니다.
    glibc버전이 2.3.4이상에서 CUBRID사용을 권장 하고 있습니다.
    사용하시는 리눅스의 버전이 낮으므로 glibc호환이 되지 않을 것입니다.
    glibc,libstdc을 업그레이드 하여 CUBRID를 사용할 수 있으나 다른 문제를 발생시킬 수가 있습니다.
    그외 리눅스의 필요한 package를 설치하는데 문제가 발생할 수 있으므로 리눅스 버전 upgrade를 권장합니다.

    이용에 감사드리며, 좋은 성과 있으시길 바랍니다.
  • ?
    victory 2009.01.22 20:14
    위에 글 올린 사람입니다.
    [root@UnetwareVersantDB CUBRID]# rpm -qa|grep glibc
    glibc-utils-2.3.2-95.27
    glibc-kernheaders-2.4-8.34.1
    glibc-common-2.3.2-95.27
    glibc-headers-2.3.2-95.27
    compat-glibc-7.x-2.2.4.32.6
    glibc-2.3.2-95.27
    glibc-profile-2.3.2-95.27
    glibc-devel-2.3.2-95.27

    ===> 현재 저희 리눅스 서버에 glibc-2.3.2-95.27  가 설치되어 있는데 엔지니어분께서   답변 주시기를 glibc-2.3.4 를 설치하셔야 한다고 하시고,

    또, libstdc++.so.5 대신 libstdc++.so.6을 바꿔주는것이 필요하다고 하시는데

    이렇게 한다고 해도 cubrid를 보장하지는 않는다고 합니다.

    현재 레드햇 버전(3.2.3)이 낮으므로, Redhat ES4.0 으로 upgrade하는것이 좋다고 답변주셨습니다.

    감사합니다.

List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 SQLGate for CUBRID 영구 무료 라이선스 제공 file admin 2020.04.09 1577
84 오라클의 contains()문과 비슷한 기능을 소개해주세요 1 타이거팀 2009.02.17 35164
83 ODBC 이용 데이터 입력 중에 ... 3 ApiClasser 2009.02.16 12510
82 어찌해서 설치는됫는데.. 1 가루구 2009.02.16 14479
81 큐브리드설치에러;; 1 가루구 2009.02.14 12563
80 큐브리드 메니져로 쿼리 결과 조회시#2 1 file ApiClasser 2009.02.14 12793
79 [질문]재설치 실패... 2 file 야매코더 2009.02.13 12747
78 VB ADO 사용 관련 문의를 드립니다. 1 늘푸른거북이 2009.02.13 17332
77 큐브리드 메니져로 쿼리 결과 조회시 3 ApiClasser 2009.02.13 13512
76 OLEDB 연결 시 에러 발생 4 늘푸른거북이 2009.02.12 22071
75 프로그램 개발 후 배포 관련 3 늘푸른거북이 2009.02.12 25302
74 cubrid 2008 windows버전에서의 CUBRID_Service_Tray 실행오류 2 마비토 2009.02.12 14122
73 [질문]큐브리드 설치관련입니다. 2 file 야매코더 2009.02.12 13470
72 [replication] 성능에 대한 질문입니다. 2 kkckc 2009.02.10 16635
71 cubrid manager에서 DB 권한 2 2~40자? 2~40byte? 2009.02.07 13826
70 OLEDB insert관련 질문입니다. 1 garfield39 2009.02.05 16247
69 DWMAPI.dll 관련 오류 2 file GGG특별대원 2009.02.04 33138
68 C/C++ 지원하는 Connection Pool API 는 없나요? 2 tekkal 2009.02.03 20903
67 solaris와 hp-unix 지원 관련 2 tekkal 2009.02.03 15982
66 PHP 에서 cubrid_connect 실패. 1 별의목소리 2009.02.03 14308
65 Clob Type. 1 tekkal 2009.01.31 18453
Board Pagination Prev 1 ... 169 170 171 172 173 174 175 176 177 178 Next
/ 178

Contact Cubrid

대표전화 070-4077-2110 / 기술문의 070-4077-2147 / 영업문의 070-4077-2112 / Email. contact_at_cubrid.com
Contact Sales