Background Image

FORUM

조회 수 36 추천 수 0 댓글 13
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄 첨부


* 질문 등록 시 다음의 내용을 꼭 기입하여 주세요.

OS
Linux Ubuntu 18.04 
CUBRID Ver.
11.1
CUBRID TOOL Ver.
[도움말]-[버전정보] 확인
응용 환경(API)
python 3.9


* CUBRID 응용 오류, SQL 오류 또는 SQL 튜닝 관련된 문의는 반드시 다음의 내용을 추가해 주세요. 비밀글이나 비밀 댓글도 가능합니다.
* 저희가 상황을 이해하고, 재현이 가능해야 알 수 있는 문제들이 많습니다. 가능한 정보/정황들을 부탁합니다.

 

에러 내용 및 재현 방법 재현 가능한 Source와 SQL
관련 테이블(인덱스, 키정보 포함) 정보 CUBRID 홈 디렉토리 아래 log 디렉토리 압축


-------------- 아래에 질문 사항을 기입해 주세요. ------------------------------------------------------------------------

Python 설치 및 설정

Linux/Unix

Linux, Unix 및 유사 운영체제에서는 다음과 같은 세 가지 방법으로 CUBRID Python 드라이버를 설치할 수 있다.

기본 환경

소스코드로 설치(Linux)

소스코드를 컴파일하여 CUBRID Python 드라이버를 설치하려면 Python Development Package가 필요하다.

  1. CCI 드라이버 빌드하기 위해 GNU Developer Toolset 8 또는 그 이상이 필요하다.

  2. 소스 코드를 https://www.cubrid.org/downloads#python에서 다운로드한다.

  3. 다음 명령어를 실행하여 원하는 위치에 다운로드한 파일의 압축을 해제한다.

    tar xvfz cubrid-python-11.1-latest.tar.gz
    
  4. 압축을 해제한 디렉터리로 이동한다.

    cd RB-11.0.0
    
  5. 드라이버를 빌드한다. 이 단계와 다음 단계는 루트 사용자 계정으로 실행해야 한다.

    python setup.py build
    
  6. 빌드한 드라이버를 설치한다.

    python setup.py install

 

===> 위와 같이 따라서 설치 진행 중 python setup.py build 명령어를 수행하면 사진과 같은 오류가 발생합니다. 해결 방법을 알 수 있을까요??

 

  • ?
    kisoo 2023.01.17 16:40
    OS (Linux) 종류 및 version을 알려주세요.
  • ?
    h2h2 2023.01.17 16:42
    Ubuntu 18.04 입니다!
  • ?
    kisoo 2023.01.17 17:03
    오류가 발생한 typeset은 shell 변수를 정수형으로 한정한다는 명령이고 Ubuntu에도 적용되는 것인데
    왜 오류가 발생했는지 모르겠네요. 제가 Ubuntu18이 없어서 22.04 LTS에서 봤는데 typeset 명령 자체는 오류가 없던데요.
    일단 cci-src/build.sh을 vi등으로 edit 해서 typeset -i 명령을 주석처리하고 다시 진행해 보시기 바랍니다.
    (결과를 알려주세요)

    #typeset -i major_version
    #typeset -i minor_version
    #typeset -i patch_version
  • ?
    h2h2 2023.01.17 17:10

    주석처리하고 진행하면
    typeset 오류는 사라지고 나머지 오류만 나옵니다!

    build.sh: 55: build.sh: Syntax error: "(" unexpected
    CCI static lib not found. Exit.

    이미지 : cubrid_오류2.png

  • ?
    kisoo 2023.01.17 17:38
    저희가 현재 support하는 python version이 3,6 까지 입니다.
    Ubuntu 22.04 LTS python 3.10.04에서 실행하니 말씀하신 오류가 그대로 재현됩니다.
    현재는 python 3.6 이상은 지원하지 않음을 미안하게 생각합니다.
    python 3.6이 가능하시다면 아래와 같이 진행하시기 바랍니다.
    3.6 이상의 version support는 빠른 시간안에 가능하도록 하겠습니다.

    $ wget git@github.com:CUBRID/cubrid-python.git
    $ cd cubrid-python
    $ git submodule init
    $ git submodule update
    $ python setup.py build
    $ python setup.py install
  • ?
    h2h2 2023.01.18 11:02
    connection timed out 에러가 나오는데 혹시 이것도 저의 문제일까요??
  • ?
    kisoo 2023.01.18 11:06
    connection timed out 에러가 정확히 어떤 상황에서 발생하는지요?
    상황 설명을 좀 구체적으로 해주세요.
  • ?
    h2h2 2023.01.18 12:39
    파이썬 3.6으로 변경 후
    wget git@github.com:CUBRID/cubrid-python.git 이 명령어를 입력하면
    connection timed out 에러(사진 첨부 - time_out.png)가 발생합니다.
  • ?
    kisoo 2023.01.18 12:59
    제가 실수했습니다. 미안합니다. wget이 아니고 'git clone' 이었습니다.

    $ git clone git@github.com:CUBRID/cubrid-python.git
    $ cd cubrid-python
    $ git submodule init
    $ git submodule update
    $ python setup.py build
    $ python setup.py install
  • ?

    python 3.6으로 변경 후 위의 명령어를 진행해 보았지만
    이전과 같이 python setup.py build 명령어 부분에서 같은 에러가 발생합니다..
    사진첨부 - cubrid_설치오류3.png

  • ?
    h2h2 2023.01.18 13:38

    설치 완료했습니다!! 파이썬 3.9에서도 설치까지는 가능한 점 확인하였습니다!

    하지만 tar 파일로 설치하는 경우에는 여전히 오류가 발생합니다. tar 파일로는 설치할 수 없는 것인지요??

    그렇다면 git clone으로 설치 버전은 어떻게 확인할 수 있을까요??

  • ?
    kisoo 2023.01.18 13:45
    수고하셨습니다.
    Python 3.9를 지원하는 CUBRID Python Driver가 빨리 출시되도록 노력하겠습니다.
  • ?
    h2h2 2023.01.18 13:50
    감사합니다.
    git clone으로 설치한 경우 cubrid 11.2버전과도 호환이 되는지 알 수 있을까요??

List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 SQLGate for CUBRID 영구 무료 라이선스 제공 file admin 2020.04.09 2955
3791 큐브리드 컬럼 디폴트값 1 new 백수인 2023.02.06 1
3790 ddl_audit_log=yes 가 없을때 디폴트 값 2 바람발마발 2023.02.01 22
3789 numeric type 의 입력 가능한 최대 값 1 정우아빠 2023.01.31 27
3788 집합함수 이용 시 정렬 관련하여 문의드립니다. 2 플레이어블 2023.01.27 32
3787 안전한 암호화 알고리즘 사용 문의드립니다. 1 보안진단 2023.01.27 37
3786 뷰를 이용한 조인쿼리 시스템 에러 문의 2 플레이어블 2023.01.19 46
3785 설시치 문의 드립니다. 4 file 큐브리드궁금 2023.01.18 63
3784 임의용량에 대해 문의 드립니다. 1 김은지 2023.01.18 25
3783 윈도우용 python 드라이버 설치 오류 1 리치타이거 2023.01.18 17
» cubrid 드라이버 설치 오류 13 file h2h2 2023.01.17 36
3781 큐브리드 버전 업그레이드 관련 문의 드립니다. 1 초코초코초 2023.01.17 23
3780 python 3.9 지원 문의 1 리치타이거 2023.01.17 24
3779 Python Cubrid DB 연동 시 import _cubrid 오류 1 이노무소오파 2023.01.13 22
3778 cci에서 패스워드 암호화 사용 방법 1 가을이아빠 2023.01.12 24
3777 데이터베이스 백업, 복구(backupdb, restoredb) 1 wiz 2023.01.12 38
3776 실리콘 맥(M1, ARM) 큐브리드 매니저 지원 문의 2 큐유저 2023.01.09 47
3775 attribute가 AUTO_INCREMENT로 생성됐는지 확인할 수 있는 딕셔너리는 무엇인가요? 3 새옹지마 2023.01.08 41
3774 varchar <-> collection으로 변환이 가능한가요? 1 새옹지마 2023.01.08 18
3773 SET, MULTISET, LIST과 같은 컬렉션 타입 컬럼에 저장된 원소의 갯수를 알고 싶습니다. 1 새옹지마 2023.01.06 37
3772 JDBC로 SET 타입의 데이터를 get/set 하는 메소드는 각각 무엇인가요? 4 새옹지마 2023.01.04 81
Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 ... 190 Next
/ 190

Contact Cubrid

대표전화 070-4077-2110 / 기술문의 070-4077-2113 / 영업문의 070-4077-2112 / Email. contact_at_cubrid.com
Contact Sales