Background Image

FORUM

조회 수 30733 추천 수 0 댓글 3
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
[김범준님의 질문]
첫째, 설치되있는 java가 별도로 설치하신 것인지 타제품 설치시 같이 설치된 것인지를 확인해 주시기 바랍니다.
둘째, 1.4버전에서도 사용 테스트가 되었으나 1.5사용을 권장합니다. 가능하시다면 1.5에서 같은 작업 테스트를 요청드립니다.
셋째, 추가적인 확인 위하여 사용하시는 환경에 대한 추가 정보(OS 등)를 부탁드립니다. 좋은 주말시간 되세요.

첫 째, JDK는 sun사에서 제공하는 것을 제가 설치 한 것입니다.
둘 째, JDK가 두 개 깔려 있습니다. 개발환경에서는 1.4버전으로 컴파일을 해야해서요. 그래서 1.4와 1.6이 두개 깔려 있습니다. 해서 제가 여쭤봤습니다. 1.6이 깔려 있는 것을 지정해서 Cubird Manager가 실행할 수 있겠끔. 수동으로 Classpath를 지정해 줄 수 있는 지요. 윈도우 환경설정과 별도로 Cubrid만의 path설정할 수 있는지요. 그런데 답변은, JDK가 잘 설치되어있음 아무이유 없이 잘 돌아간다는 것 뿐이었습니다.
셋 째, 컴퓨터 환경입니다.

CPU: Intel Core2Duo L7500
RAM: 4G(2G[800Mhz]X2)
O/S: Windows Vista Business K Service Pack 1
Form: Laptop(Lenovo X61s)
Eviroment:
JAVA_HOME = C:j2sdk1.4.2_12
JAVA_HOME1 = C:jdk1.6.0_07
[JAVA_HOME1은 다른 곳에서 쉽게 사용하려고 만들어 놓았으며 path설정에는 쓰지 않았습니다.]

추가로 제 로컬에 Oracle이 깔려 있습니다. 물론 평상시에는 서비스를 죽여 놓기 때문에, Cubrid가 돌아 가는데, 아무 문제 없을 듯 하지만, 그래도 모르니 말씀을 드립니다.

  • ?
    cubebridge 2008.12.02 00:59
    답변이 치제 되어 죄송합니다.

    질문을 주신 각버전에 대해서 java1.4.2_12버전을 설치하여 테스트한 결과 CUBRID7.3은 정상 수행되었으나  CUBRID2008은 말씀하신 오류가 발생한 것을 확인하였습니다. 이에 대해서는 java버전과 CUBRID 각버전의 호환 사항을 확인하여 추가 답변을 드리도록 하겠습니다.

    사용에 문제가 되었던 부분은 위에 말씀드린 것 같이 java호환성 문제 때문입니다. 이에 따라 추가 질문하신 부분에 대해서 답변을 해드리겠습니다.

    1.6이 깔려 있는 것을 지정해서 Cubird Manager가 실행할 수 있도록 현재 지원이 되고 있지 않습니다. 따라서 현재 컴파일을 위해 설치해 놓으신 1.4버전에서 CUBRID2008을 수행하려 하면서 에러가 발생한 것입니다. 현재로써 1.6 JRE를 우선환경으로 변경하지 않는 한 Cubrid Manager(CUBRID2008 용)를 사용하실 수가 없습니다.

    이에 대한 기능 지원이 바로 될 수 있는 사안은 아니나 문의내용을 저희 제품 개선안으로 추가하도록 하겠습니다.
    큐브리드에 대한 많은 관심 감사드리며, 많은 추가 질문 부탁드립니다.

    좋은 하루 되세요.
  • ?
    GoFly 2008.12.02 01:30
    부탁 드리겠습니다.
    Eclipse 같은 경우 기본으로는 윈도우의 환경설정에 따라가지만 Eclipse.ini를 고치면 사용자가 원하는 JDK 버젼으로 Eclipse 실행을 지정할 수 있습니다. 그래서 제 컴퓨터에선 Eclipse가 JDK1.6으로 돌고 Compile은 1.4로 하고 있습니다.

    환경설정을 우선으로 하되, 만약 ini파일과 같은 곳이나. .conf파일에 명시를 임의적으로 하게 되면 그 쪽을 참조해서 Cubrid Manager가 실행 될 수 있게 해 주셨으면 합니다. 그나 저나 이제 2008버젼 나왔는데 이거 반영되려면 시간쫌 걸리겠네요;;;
    감사합니다.
  • ?
    cubebridge 2008.12.02 01:35
    해당 내용에 대해서 내부적으로 확인할 것입니다.

    의견 감사드립니다.

List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 SQLGate for CUBRID를 사용해 보시기 바랍니다!!! file admin 2019.07.31 323
26 데이터바인딩? 2 우페 2008.12.12 17944
25 OleDbCommand 를 사용하는데 다음 같은 에러가 발생합니다. 3번째 2 hades 2008.12.10 18941
24 OleDbCommand 를 사용하는데 다음 같은 에러가 발생합니다. 2번째.. 1 hades 2008.12.10 20670
23 OleDbCommand 를 사용하는데 다음 같은 에러가 발생합니다. 2 file hades 2008.12.10 22237
22 인코딩 문의. 1 우페 2008.12.09 19082
21 대량 데이터 입력 방법 중에서요.. 2 우페 2008.12.09 18530
20 설치관련 다시 질문 올립니다. 2 해바라기 2008.12.05 17782
19 csql 유틸리티에서 쿼리플랜 확인 1 asteroid 2008.12.05 28136
18 2008 RC1.1 매니저 실행에 대한 문제점과 임시적인 해결책 1 GGG특별대원 2008.12.05 27161
17 DB 서버 자동 실행 문의. 1 우페 2008.12.04 30419
16 CUBRID 설치 문의 입니다. 1 해바라기 2008.12.04 27259
15 Cubrid 2008 srpm 공개 여부? 1 김정균 2008.12.04 41286
14 시간표현 문제 2 asteroid 2008.12.02 30134
» 안녕하세요 김범준님.. 3 GoFly 2008.12.01 30733
12 linux server 환경에서 php 버전은 어떤걸로 선택해야하는지. 1 거기 2008.11.30 66295
11 더 정확히 하자면 서버실행은 되지만 Manager가 실행이;;;; 1 file GoFly 2008.11.28 49302
10 JDK가 두개 설치된 경우 선택적으로 JDK를 설정 할 수 있는 방법은 없는지요 1 GoFly 2008.11.28 60311
9 델파이에서는 어떻게 사용할수 있을까요? 2 이상원 2008.11.29 65322
8 cub_master: Cannot bind local address... aborting.... Address already in use 4 박상현 2008.11.28 82879
7 update 쿼리를 이용한 시리얼 수정에 관하여 1 인경수 2008.11.27 63158
Board Pagination Prev 1 ... 145 146 147 148 149 150 151 152 153 154 Next
/ 154

Contact Cubrid

대표전화 070-4077-2110 / 기술문의 070-4077-2147 / 영업문의 070-4077-2112 / Email. contact_at_cubrid.com
Contact Sales